Altium Designer

From ivc wiki
Jump to: navigation, search

Altium Designer is an advanced schematic and PCB design software.

Base settings

  • Text height: 30mil [1]
  • Text width: 8mil
  • Grid snap: 5mil

Layer Standards

  • Mechanical 1 – Board Outline (along with the Keep-Out Layer, but that can be used for other things also)
  • Mechanical 2 – PCB Info (manfacturing info, added as text)
  • Mechanical 11 – Top Layer Dimensions <paired with M12>
  • Mechanical 12 – Bottom Layer Dimensions <paired with M11>
  • Mechanical 13 – Top Layer Component Body Information (3D models and mechanical outlines) <paired with M14>
  • Mechanical 14 – Bottom Layer Component Body Information (3D models and mechanical outlines) <paired with M13>
  • Mechanical 15 – Top Layer Courtyard and Assembly Information <paired with M16>
  • Mechanical 16 – Bottom Layer Courtyard and Assembly Information <paired with M15>

Libraries

From scratch to fabrication files

New project

  • Add a new PCB group by in the File menu

New Schematic

  • Create a schematic and add it to the PCB group by dragging it in the Projects panel
  • Save the board in a new project folder

New PCB

  • Create a new PCB board using the PCB Wizard on the Files panel and drag the PCB into the PCB group in the Projects panel
  • Right-click the sheet and select Options, Board Options and uncheck Display Sheet
  • Add the necessary design rules before transferring the schematic, i.e. thicker power traces for power nets
  • Save the board in the same folder as the schematic

Edit schematic symbols

  • Create a new Schematic Library to collect the new symbols, save it to a common location
  • Open the other Integrated Library or Schematic Library from the File menu and in the Project panel pick the SchLib file
  • Switch over to the SCH Library panel to view all the symbol drawings
  • In Tools, select Copy component to save it to your own Schematic Library from the list
  • Make the changes to the symbol and save it
  • To use the new symbol, open the Schematic and place a new component, select your own SchLib file to view the list of all the components

For designators, check this PCB reference designators list.

Edit footprint

  • Create a new PCB Library for the new footprints
  • Open the other PCB Library, from the File menu, with the footprint you want to edit and pick it from the Projects panel
  • Switch to the PCB Library panel to view all the footprints, pick the right one
  • In Edit, pick Copy Component to copy the entire footprint
  • Switch over to your own PCB Library in the Projects panel, the PCB Library, and right-click in the Components list to Paste 1 Components to the library
  • Edit the footprint and save it for later use

Make PCB footprint

  • Open your PCB Library and switch over to PCB Library panel
  • In Tools, pick IPC Compliant Footprint Wizard to make common SMD footprints or Component Wizard for all other kinds
  • The footprint is added to your current open PCB library

If the component has a non-standard/IPC footprint, make a custom footprint:

  • Duplicate one of the other footprints which looks like the new footprint you need
  • Rename the footprint and start editing the pads, silkscreen and 3D bodies
    • Use the X and Y values from the datasheet to manipulate the X and Y properities for each pad in the component
    • Define the pin numbers for each pad, if there are multiple pads with the same net use the same pin number for every pad in the net

Create component overview layout

To make it easier to assemble the prototype of the board, it is handy to know where each component lands (C1, R1, etc.) - espesially if you have disabled designations.

  • Open the PCB and shelve any plane pours, disable the side of the board where there are no components (bottom right button)
  • In the query input, type "IsComponent"
  • Open the PCB Inspector and toggle "Show names"
  • Clear the query input by clicking on the x button
  • Now the designators will be centered and align on each of the components
  • Use Snagit or print screen button to capture a PNG and use for reference together with the CSV

Define footprints for components

  • In the schematic, select Footprint manager in the Tools menu
  • Go through the list to by clicking Add and Browse to pick the correct footprint for each component
  • Right-click to select Set As Current to make it active

Transfer design

Import schematic to PCB

  • Compile the schematic in the Project menu and watch the System, Messages window for error messages, double-click the line to focus on the fault
  • In the schematic, select the Design menu and Update PCB to transfer the design
  • Click Validate Changes and Execute Changes, watch for errors after the transfer has been performed
  • All the components footprints will now be placed besides the PCB board outline ready to be placed and routed

If one of the transfers fails with a message "unknown pin", do:

  • Open the PCB Library for the footprint and find the footprint in the PCB Library panel
  • Change the name and designator to match the schematic symbol, i.e. pin 1 in the symbol should be pin 1 on footprint
  • Save and switch over to the footprint manager to change to the new footprint/make sure the pin designators has been updated

Remove rooms from import

By default Altium adds rooms to the PCB even if you don't use them in the schematic.

  • Open menu Project -> Project Options -> ECO Generation
  • Select Add Rooms and then choose Ignore Differences from the drop-down menu on the right
  • Open Design -> Rules -> Placement -> Room Definition and remove any rooms defined

Routing board

Traces

  • Place the components in a favorable way with common components grouped close together to minimize trace length
  • Use Interactive Routing from the Place menu to lay the traces
  • It might be useful to perform a Autoroute to check if there is problems or better ways to place the components, undo the autoroute
  • Shortcut for Interactive Routing is P+T

Re-routing board

  • Use the Interactive Routing tool to place a new trace, the old one will automatically be erased when the new on is laid
  • To unroute a trace use T+U+C

Adding via and changing layer automatically

  • While routing a trace, press "+" and click to add a via and change signal layer

Quickly change via or trace size

  • Press the 3 and 4 button while placing a via or trace to change to to preferred, max or min according to the set rules

Ground pour planes

  • Place a Polygon Pour from the Place menu
  • Select Solid and change the Net to GND
  • Click the four corners of the board to mark the area where the copper should pour/remain
  • To make it easier to place and route the board, hide the pour by right-clicking on the board, Options, Show/Hide, and Hide Polygons
  • After moving parts, update the pour in Tools Polygon Pour and Repour All Polygons

Import graphics and logos

To add graphics to the PCB silkscreen or solder mask:

  • Open the design with transparent background in Photoshop in PaintBrush
  • Resize to 1000px width to get a good resolution
  • Select all and ctrl+c to copy to clipboard
  • Switch to Altium PCB document and ctrl+v to paste it into the board
  • Use the square handles to resize the logo - only possible right after pasting the graphic
  • In the PCB Inspector switch layer to Top Overlayer or Bottom Overlay
  • To flip or mirror the design, mark the design, Edit, Select and Flip selection

Change PCB thickness

The thickness of the PCB shown in 3D view can be changed by:

  • Selecting menu Design -> Layer Stack Manager
  • On the diagram of the PCB section cut, double-click the Core marker
  • In the dialog box, change Thickness to 0.6, 0.8, 1.0, 1.6 or 2.0 (or any other value)

If your PCB copper thickness is anything else than 1 oz., you can change the copper thickness by

  • Double-clicking Top Layer and Bottom Layer
  • Change the Copper thickness value to 1.4 mil for standard 1 oz., 0.8 mil for 1/2 oz. or 2.8 mil 2.8 oz.

Board shape

If no board outline has been define before:

  • Select Design, Board Shape, Redefine Board Shape and click on the 4 corners to outline the board size
  • Then select Create Primitives From Board Shape, 4mil width, put the board outline on the Keep-out layer (Gerber friendly, GKO file)

If you already have the lines in the Keep-out layer positioned:

  • Select all with ctrl+a and select Design, Board Shape, Redefine From Selected

Press 3 to view the final PCB design in 3D rendered perspective. Press 2 to go back to 2D.

Fabrication files

Gerber files

  • To get standard Gerber manufacturing files, open the PCB and select File, Fabrication Output and Gerber X2 files (install the plugins if necessary)
  • Select Format 2:5, click Plot Layers and Used on, deselect Paste, Mechanical, and Pad Master layers and enable the GKO Board Outline layer when sending to a PCB manufacturer
  • Click OK and get the Gerber files
  • Then for the drill files, go to File, Fabrication Output and NC Drill files
  • Select Format 2:5 and click OK to export the drill text file
  • Go to the project Output folder and select the required files, zip them up and send to fabricator
    • Normally include the a short PCB fab note txt, *.GBL, *.GBO, *.GBS, *.GKO, *.GTL, *.GTO, *.GTS, *.RUL, *.TXT and a *.png 3D render of the 3D view - filename e.g. fpv_light_strip_rev3-seeedstudio.zip

IPC-D-356 netlist

Including the netlist from your design reduces the risk that the PCB fabricator accidentally prepares your board with the wrong setup (the Gerber and Drill files are not used directly on the machines but manipulated to fit the fabricators machining tolerances and properties).

  • Export the PCB design to Gerber and NC Drill files, go to the generated CAMtastic1.Cam file tab
  • Import the NC Drill file using File -> Import -> Drill and pick the generated *.TXT file in the project Output folder
  • Delete all layers in the CAMtastic panel except the copper layers and drill holes, i.e. keep *.GTL, *.GBL, and *.TXT layers
    • A dialog box will open to confirm the new layer order, the default values are good and click Ok on both
  • Now, extract the netlist using Tools -> Netlist -> Extract and the Nets tab in the CAMtastic panel will be populated, click on the nets to highlight the different copper traces
  • Export the IPC-D-356 netlist by selecting File -> Export -> IPC-D-350, define the output folder and click Ok

Multiple board design

To keep multiple PCB boards design updated, each separate board has to be kept in individual .PcbPrjct files. All the schematics are then added to a master project with only ScDoc files, no PcbDoc files. This keeps all the net and rules the same for the schematics but the PCB layout nested. See this article for details.

Supplier part data automatically in schematic

It is possible to add supplier links on components in the schematic and get live stock and pricing updates when exporting the BOM. The quantity and pricing is directly from the supplier. It works very well indeed compared to what you might imagine.

  1. Install the supplier plug-ins under DXP -> Plugins and updates, select Mouser and Digikey, click Apply
  2. Fix a few settings under DXP -> Preferences -> Data Management or System (depending on version) -> Suppliers, check or uncheck the suppliers you prefer, enter the username and password for accurate pricing, select currency and region - if you put the component part number in another field than the default specify it under Suggested Keywords to make it autofill the search field
  3. Open your schematic and right-click on a component and select Supplier Links
  4. Click Add and the search field should be pre-populated with the part number you already have entered into the component
  5. Click Search and a list of possible part candidates should start to trickle in
  6. Select the right part or from multiple suppliers, and add it to the list, click Ok and you are done - you can right-click the header to add more columns to the list, e.g. stock and RoHS status
  7. Go to Reports -> Bill of Materials and scroll down the list until the Supplier* fields appear, click visible on e.g. the Supplier part number and Supplier pricing - the pricing is fetched live from the supplier (not from Altium)!

Changes to default preferences

The following is a list of my own changes, and for my own reference, of changes I make to the default installation of Altium:

  • PCB Editor -> Display -> "Antialiasing Quality: 2x" - For better graphics representation in 2D and 3D

References